Partial Screen Outage

Incident Report for Actionfigure Ecosystem

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 18:52 EDT

Identified

Partial outage affecting Actionfigure Screens running on Transitbox/Chromebox devices.
Posted Jul 15, 2026 - 17:31 EDT
This incident affected: Actionfigure Screen - "Select" and "Premium" Packages.